Re: [Jastadd] _at_Override annotations in Java 6

From: Jesper qvist <jesper.oqvist_at_cs.lth.se>
Date: Thu, 10 Jan 2013 10:07:37 +0100

Typo. Should have been: ...excluded at the *end* in order to avoid
multiple inclusions.

On 01/10/2013 10:05 AM, Jesper qvist wrote:
> Oops, I misread the build.xml file. The ConstantExpression.jrag and
> Variable.jadd files from
> Java7Frontend must be included the JastAdd invocation *before*
> anything else.
>
> They are not redundant, they are just excluded at the in order to
> avoid multiple inclusions.
>
> /Jesper
>
> On 01/10/2013 09:55 AM, Jesper qvist wrote:
>> Hi Eric,
>> The following JastAdd files should be excluded from Java1.4Frontend:
>>
>> * Literals.ast
>> * CatchClause.ast
>> * Variable.jadd
>> * BytecodeAttributes.jrag
>> * BytecodeDescriptor.jrag
>> * BytecodeReader.jrag
>> * ConstantExpression.jrag
>>
>> The following should be excluded from Java7Frontend when compiling
>> Java7Backend:
>> * ConstantExpression.jrag
>>
>> I got this list from looking at the build.xml file of Java7Backend. I
>> do not know why the
>> ConstantExpression.jrag file is needed in Java7Frontend, I think it
>> is obsolete actually.
>> It appears that it is also excluded from the Java7Frontend build.xml.
>>
>> Take a look at the build.xml file to see the order in which flex
>> files are concatenated,
>> because it is important. The macros.flex of Java7Frontend needs to be
>> concatenated
>> after preamble.flex and the Java 1.4 version should be excluded. Also
>> note the order
>> of Literals.flex.
>>
>> /Jesper
>>
>> On 01/10/2013 09:17 AM, Eric Bodden wrote:
>>> Hmmm, I have just tried integrating the Java7Frontend into Soot but I
>>> am having trouble because some of the .ast and .jrag files seem to
>>> clash with those of the Java1.4Frontend and Java1.5Frontend. (I get
>>> duplicate declarations of AST nodes and attributes.) Is this a known
>>> issue? Is there a known list of files I should exclude from the build?
>>>
>>> Cheers,
>>> Eric
>>>
>>> On 10 January 2013 08:57, Jesper qvist <jesper.oqvist_at_cs.lth.se>
>>> wrote:
>>>> Yes, the Java 7 implementation is stable. Unfortunately we do not
>>>> have as
>>>> many tests for the Java 7 implementation as we do for Java 5.
>>>>
>>>> If you want to use the new Override semantics with the Java5
>>>> frontend you
>>>> can copy the file Java7Frontend/Override.jrag into Java1.5Frontend.
>>>>
>>>> /Jesper
>>>>
>>>>
>>>> On 01/10/2013 08:46 AM, Eric Bodden wrote:
>>>>> Hello.
>>>>>
>>>>>> The Java 7 frontend implements the new Override semantics. For
>>>>>> historical
>>>>>> reasons it is not implemented in the Java 5/6 frontend.
>>>>> Thanks for the quick response. Is this frontend considered stable? I
>>>>> am asking because I would consider switching Soot/abc to it then.
>>>>>
>>>>> Eric
>>>>
>>>> _______________________________________________
>>>> JastAdd mailing list
>>>> JastAdd_at_cs.lth.se
>>>> https://mail1.cs.lth.se/cgi-bin/mailman/listinfo/jastadd
>>>
>>>
>>
>> _______________________________________________
>> JastAdd mailing list
>> JastAdd_at_cs.lth.se
>> https://mail1.cs.lth.se/cgi-bin/mailman/listinfo/jastadd
>
> _______________________________________________
> JastAdd mailing list
> JastAdd_at_cs.lth.se
> https://mail1.cs.lth.se/cgi-bin/mailman/listinfo/jastadd
Received on Thu Jan 10 2013 - 10:07:15 CET

This archive was generated by hypermail 2.3.0 : Wed Apr 16 2014 - 17:19:06 CEST