Re: [Jastadd] Configurable Front-End?

From: Jesper qvist <jesper.oqvist_at_cs.lth.se>
Date: Tue, 17 Jul 2012 12:26:53 +0200

Unfortunately there is no such option in JastAddJ.

I suppose it would be possible to build the three versions of JastAddJ
using different main classes and then invoke the correct main method
depending on which compatibility level is required.

/Jesper

On 07/17/2012 01:35 AM, Marc-Andre Laverdiere-Papineau wrote:
> Hello,
>
> I am a Soot user. As you may know, Soot uses JastAddJ as its Java
> front-end.
>
> Sadly, it hasn't been updated in a while, which means that Soot can't
> handle newer constructs.
>
> I am volunteering to update it. The thing is, we'd like to be able to
> switch between Java versions. As far as I can tell, things are woven
> in statically in JastAddJ's different front-end.
>
> Is there some kind of option that we could give to JastAddJ to operate
> within one mode (1.4, 5, 7) or the other?
>
> Regards,
>
Received on Tue Jul 17 2012 - 12:25:14 CEST

This archive was generated by hypermail 2.3.0 : Wed Apr 16 2014 - 17:19:06 CEST